Solitaire - Choose to Lose Lite

from Choose To Lose, originally released 18th April, 2012

Note : The game is compatible with the following devices only - iPod touch 4th Gen , iPhone 4, iPhone 4S , iPad2.
...


Recent posts about Solitaire - Choose to Lose Lite
discussion by